Vault Job Processor is unable to create a .dwf from a .pdf

July 29, 2025 Shawn Heator

Issue:
With the Job Processer running, the Job Processor shows a “Pending” job that does not begin to process. The Job Queue displays the “Pending” job is Job type:Autodesk.Vault.DWF.Create.pdf. 

 

Attempts to Pause and restart the Job Processor do not prompt the job to process. Other jobs, such as Synchronize Properties or Create PDF, will continue to process properly.

Causes:
A DWF.Create.pdf job is created when a user selects a PDF in the Vault Client and tries to “Update” the view. To send the job to the Job Processor, the “Update” must have the selection “Queue Update” already selected. The command “Queue Update” sends the job to the Job Queue for the Job Processor to complete.

 

Once the job is sent to the Job Processor, the job will stay in a “pending” state because the Job Processor does not hae a “Job Type” for creating .dwf files from a .pdf.

 

To view the jobs that can be processed by the Job Processor, go to the Job Processor and select Administration>Job Types.

The Job Types dialog box will appear. The image below displays all .dwf.create jobs that can be processed by the Job Processor.

 

The problem “pending” job type (Autodesk.Vault.DWF.Create.pdf) is not in the list of Job Types for the Job Processor.

Solution:
Both PDF’s and DWF’s are alternate file formats to view Autodesk files and there is not an “out of the box” method to create a .dwf file from a PDF. PDF’s are generally created from Autodesk drawings that need to be sent to another user or group without sending possible proprietary data. DWF files, also known as “visualization” files, are intended to be a quick way to view an Autodesk drawing or file. 

Since there is not a method to generate a .dwf file from a .pdf, the job can be removed from the Job queue. If a user would like to view a .pdf file, it is best to open the file instead of attempting to create a visualization.

About the Author

Shawn Heator

Technical Support Specialist

Follow on Linkedin More Content by Shawn Heator

No Previous Articles

Next Article
Vault Job Processor–Failed to acquire a license
Vault Job Processor–Failed to acquire a license

Jobs in the Vault Job Queue are showing a Status of “Error,” and the Results indicate that the issue is the...

×

Get Tips Delivered.

Subscribe to Email Updates.

First Name
Last Name
Country
Thank you!
Error - something went wrong!