Ribbon tools disappear when moving Autodesk Design Review app to a secondary monitor.

September 29, 2025 Shlomo Okoye

Issue:

After dragging the Design Review app to a secondary monitor, or opening it on a monitor other than the primary monitor, all the ribbon tools disappear, leaving a blank space.

 

 
Causes:

This issue is typically replicable on a multiple monitor setup when the primary monitor and secondary monitor(s) have different display scaling settings.

 


Solution:

The issue can be resolved by either applying a uniform display scaling to all monitors, or overriding DPI settings for the program.

Option 1 – Apply a uniform display scaling to all monitors:

    1. Right-click on the desktop and select ‘Display settings’.
    2. Navigate to the ‘Scale and layout’ section and use the dropdown menu to choose your preferred display scaling.
    3. Apply the same value to all connected monitor(s).

 

Option 2 – Override DPI settings:

    1. Right click on the Autodesk Design Review shortcut on the Desktop and open the Properties.
    2. Go to the 'Compatibility' tab and click on 'Change high DPI settings'.
    3. Tick the checkbox to 'Override high DPI scaling behavior'.
    4. On the dropdown menu, choose 'Application'.
       
    5. Select ‘OK’ and restart the application.

 

Previous Article
All elements in Revit showing as halftoned
All elements in Revit showing as halftoned

All Revit elements display as halftoned whether object style changed or not.

Next Article
Materials reset when syncing upgraded Twinmotion file.

×

Get Tips Delivered.

Subscribe to Email Updates.

First Name
Last Name
Country
Thank you!
Error - something went wrong!