Related Software:
All Autodesk Revit and Revit LT products.
Issue:
When trying to print 3D views or sheets that contain 3D views, Revit freezes and stops responding, and in some cases Revit may crash outrightly.
This error occurs only in perspective views where toposurface or toposolid is visible. Orthographic views remain unaffected.
Causes:
Toposurface/toposolid contain too many points.
Solution:
Simplify the toposurface/toposolid:
-
- Select the toposurface/toposolid to reveal the "Modify | Topography" Tab, then click on “Edit Surface”
- From the tools panel, click on "Simplify Surface"
- Type in an accuracy to simply with, then select OK.
- Now try to print again.
- Select the toposurface/toposolid to reveal the "Modify | Topography" Tab, then click on “Edit Surface”
Note: You are more likely to experience this issue when a Toposurface/Toposolid has over 81000 points.
Workaround:
In cases where you intend to export and render high quality terrain features in a 3rd party software and don’t find the solution above as a viable option, or for any other reason at all you do not wish to simplify the surface, you should still be able to print by using the following workaround:
-
- Set the view/sheet to print using Raster processing:
- Open the Print Setup from the Print Dialog,
- Set Hidden Line Views to ‘Raster Processing’ and select OK.