Issue:
Inventor crashes and completely exits the application when placing a constraint. There may or may not be a Crash Error Report (CER) generated when the application closes. If Inventor crashes and produces a CER, then be sure to submit the report to Autodesk. Be sure to input your email address into the CER report, if the option is available, before the CER is submitted. There are many reasons that Inventor may crash when placing a constraint, but a common problem is related to system resources.
Causes:
Inventor crashes can be caused by missing Autodesk updates, recent Windows updates, bad or outdated graphics cards, corrupt files, corrupt Inventor or Windows user profiles, and more factors. The following link, from Autodesk, has more information about the many possible culprits that may cause Inventor performance and crashing issues.
https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Troubleshooting-Inventor-Stability-Crash-and-Hang-Issues.html
Solution:
If an Inventor crash occurs after placing a constraint, then the problem is likely related to system resources for the graphics card. We have recently observed crashes that only occur on systems that either have a bad/outdated graphics card driver or have a graphics card that does not meet the minimum requirements for Inventor.
System graphics play a particularly significant role for Autodesk Inventor. When placing a constraint within an Inventor assembly, Inventor will preview the position of the object being constrained before the action is completed. The preview requires additional graphics resources to be consumed beyond the resources required for all other applications running on the system. Once the constraint is placed, Inventor physical properties on the assembly have changed and the application will attempt to update the view and properties. An Inventor crash occurs when the graphical resources necessary to display the model exceed the available resources.
1. Log into your Autodesk account at https://manage.autodesk.com to download and install the latest update for your installed version of Inventor.
2. If the Inventor crash continues to occur, ask a colleague to open the same assembly and attempt to place the same constraint.
a. If your colleague’s system does not crash, compare your graphics card and driver build with your colleague’s graphics card and driver build. If possible, install the same graphics card driver.
b. If both systems produce the same Inventor crash, then check both systems to ensure they both meet not only the minimum requirements for Inventor Professional but also that the graphics cards are on the list of Autodesk Certified Hardware.
https://www.autodesk.com/support/system-requirements/certified-graphics-hardware
3. Update the graphics card driver. Instead of using the Windows Update Driver command, visit the graphics card manufacturers website to obtain the latest graphics card driver.
a. If you have a Nvidia graphics card, run the download for the latest driver and use the “Custom” and “Perform a clean installation” options when prompted. See example images below.
4. If the problem continues then ensure all files are on the local hard drive (C:\). In some instances, Inventor struggles to resolve the references for files located in another location. If any files or reference files exist on a network drive or cloud drive (OneDrive, Dropbox, etc.) then move them to a folder on the local hard drive that is not accessed by another process. It may be easier to create a Pack and Go of the problem assembly (Inventor File>Save As>Pack and Go). This will package all the reference files into a single folder path. Then try opening the assembly and applying a constraint with all files located on the local drive.
If you continue to encounter any additional problems, then please contact IMAGINiT Technologies support at 888-528-4765 or support@rand.com.
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