Issue:
On launch Inventor 2023 gets a pop-up error ‘Could not start the Autodesk Desktop Connect Service. The required services (Autodesk Desktop Connect and Guided Tutorial Plugin) may have been uninstalled.’
Causes:
The Autodesk Desktop Connect Service is not installed, or the installation is incomplete.
The Autodesk Guided Tutorial Plugin may also be partially installed.
Solution:
Reinstall the Autodesk Desktop Connect Service and if needed the Autodesk Guided Tutorial Plugin. Both should show in Windows Control Panel once installed:
Reinstall Autodesk Desktop Connect Service
Go to your Inventor 2023 media folder download.
The default download location on the C drive in the Autodesk folder: C:\Autodesk\Inventor_Pro_2023_English_Win_64bit_Dlm\x64\LWS\AutodeskDesktopConnect.msi
- Right-click on the AutodeskDesktopConnect.msi file and choose ‘Uninstall’ to uninstall it.
- Once completed right-click on the file and choose ‘Install’ to install Autodesk Desktop Connect.
If the error persists in Inventor on startup run the same process on the AutodeskGuidedTutorialPlugin.msi.
Reinstall Autodesk Tutorial Plug In
Go to your Inventor 2023 download folder in:
C:\Autodesk\Inventor_Pro_2023_English_Win_64bit_Dlm\x64\LWS\AutodeskGuidedTutorialPlugin.msi
- Right-click on the AutodeskGuidedTutorialPlugin.msi file and choose ‘Uninstall’ to uninstall it.
- Once completed right-click on the file and choose ‘Install’ to install Autodesk Desktop Connect.
If this doesn’t resolve the error try the Microsoft Fix IT troubleshooter to remove Autodesk Desktop Connect Service and Autodesk Guided Tutorial Plugin.
Reinstall them both using the steps above.
- Autodesk Desktop Content Service reference article
- For previous versions of Inventor: https://resources.imaginit.com/how-tos/inventor-2020-error-could-not-start-the-autodesk-desktop-connect-service-the-required-services-autodesk-desktop-connect-and-guided-tutorial-plugin-may-have-been-uninstalled
About the Author
More Content by Joanna Gryszka