How to Locate Your BIM 360 Account ID

April 17, 2020 Heath White

Issue:

In order to renew your BIM 360 Account, you will need your BIM 360 Account ID. You are unsure of how to find your BIM 360 Account ID and/or what the BIM 360 Account ID is.


Causes:
Locating the BIM 360 Account ID may prove challenging for a couple of reasons:

  • The Account Admin has not been shown where to look for this information
  • Some companies have only been working on projects hosted on another company’s BIM 360 site since purchasing BIM 360 Design licenses, and therefore have not activated their own site and do not have a BIM 360 account ID yet.


Solution:
Important Note: To proceed, you MUST be a BIM 360 Account Admin

Use the following link: https://bim360.autodesk.com/activate/c4r-docs-account/

  • If you have an existing BIM 360 which has already been registered, you will choose Step 1 shown in the image below. (Alternatively, you can login to your active site at https://admin.b360.autodesk.com)

 

  • If you have just purchased your BIM 360 licenses or have been using another company’s site since your first purchase and have never activated your Account/Site, skip to Step 2 shown in the image below. Keep in mind that there should only be one (1) activation per account. Additional administrators can be added once the account is registered and active.

2

  • If you chose Step 1 AND you are an account administrator, you will see the following once you sign in.
    Choose the “BIM 360 Account Admin” option indicated in the image below:

3

Once you have logged into the BIM 360 Account Admin, please see the following IMAGINiT KB article for the additional steps to needed find your BIM 360 Account ID:

https://resources.imaginit.com/support-blog/where-can-i-find-my-bim-360-docs-account-id-number

This article also includes troubleshooting steps in the event you have lost your hub access.

  • If you chose Step 2 above (Activate you BIM 360 Account), you will see the page indicated in the following image. Please pay close attention to the highlighted areas before submitting the form.
  1. “Any firm using Revit 2018.3 or later that does not have an active BIM 360, Collaboration for Revit/BIM 360 Design, BIM 360 (frequently referred to as “BIM 360 Document Management”), Field/Build or Glue account.”
  2. “If you use Revit 2018.2 or an earlier version, you’ll need BIM 360 Team for Revit Cloud Worksharing. Set up your account.”

4

After reviewing the steps above, if you are still unsure of how to proceed or if you have additional questions please reach out to us here at IMAGINiT. Our team is always here to assist you.

About the Author

Heath White

Sr. Technical Support Specialist, Manufacturing

Follow on Linkedin More Content by Heath White
Previous Article
Can't Save BOM Export Setup Edits in IMAGINiT Vault Client Utilities
Can't Save BOM Export Setup Edits in IMAGINiT Vault Client Utilities

How to save edits to BOM Export Setup in IMAGINiT Vault Client Utilities

Next Article
How to Find More Materials to Use in Revit 2020
How to Find More Materials to Use in Revit 2020

Adding more materials to your options in Revit

×

Get Tips Delivered.

Subscribe to Email Updates.

First Name
Last Name
Country
Thank you!
Error - something went wrong!