Can't Save BOM Export Setup Edits in IMAGINiT Vault Client Utilities

April 22, 2020 IMAGINiT Technologies

By: Bob Felton, Solution Center MSD/DM Senior Support Specialist 

Issue:
An error occurs when you edit the BOM Export Setup and attempt to save your edited settings.


Causes:
This occurs after installing the IMAGINiT Utilities for Vault Client for any of the recent versions; 2018, 2019 or 2020.

The BOM Export Setup is accessed in the Vault Client under Tools > IMAGINiT Utilities, then select BOM Export: Admin.

1


In the BOM Export Setup screen that opens, select any of the available fields for BOM (Bill of Materials) properties to add and then click OK.

2

An Error Report dialog box opens and when the View button is clicked, a detailed crash report appears. The most notable message is this:

<ExceptionType xmlns="http://www.avatech.net/webservices/20090601">Autodesk.Connectivity.WebServices.VaultServiceErrorException</ExceptionType>
<ExceptionMessage xmlns="http://www.avatech.net/webservices/20090601">321</ExceptionMessage>
<ExceptionTarget xmlns="http://www.avatech.net/webservices/20090601">Void HandleReturnMessage

What causes this error to appear is when a Vault replication subscriber is accessed with the Vault Client.


Solution:
The confirmed solution is to log into the Vault replication publisher with the Vault Client. Then the correct permission will allow the edits to be saved.

 

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