AutoCAD Electrical : "Install the latest 64-bit version of Microsoft Access Database Engine 2016 to use the Catalog Browser"

April 5, 2022 Jeff Arbogast

Issue:

When launching Electrical. You get an error."Install the latest 64-bit version of Microsoft Access Database Engine 2016 to use the Catalog Browser".

Causes:

  • The 64-bit version of the Microsoft Access Database Engine 2016 has not been install or is corrupted.
  • Antivirus is causing files to corrupt mdb.

Solution:

 

  • Install the Microsoft Access Database Engine 2016 64-bit version from.

C:\Autodesk\AutoCAD_Electrical_2022_English_Win_64bit_dlm\3rdParty\x64\AceDataEngine\aceredist.msi

 

  • Added exceptions to your Virus Scan.

3ds, ac$, apj, bak, ctb, cui, cuix, dcl, dst, dwf, dwg, dwl, dwl2, dwt, fbx, ipt, iam, idw, ipn, ipj, lin, ma, mat, max, mb, mns, mnu, pat, pgp, rfa, rft, rte, rvt, rws, dat, slog, shp, shx, stb, sv$

.sq* (sqlite), .wdp, .ldb, .mdb, .mui, .aux, .chm, revit*.xml.zip

 

Note: We have noticed there appears to be a Microsoft update causing this issue with Autodesk Electrical 2022. Use the solution for installing the database engine to correct this issue.

About the Author

Jeff Arbogast

Manufacturing Solution Center Team Lead<br><br>Jeff is responsible for manufacturing Technical Support for both internal staff and customers. In addition to the daily activities of the support center, he helps write for the National Support Center blog, and has written online classes for the IMAGINiT training on demand site.

Follow on Linkedin More Content by Jeff Arbogast
Previous Article
Autodesk licensing error ‘the license you’re using is not valid’ or ‘Your access to <product-name> is now limited’
Autodesk licensing error ‘the license you’re using is not valid’ or ‘Your access to <product-name> is now limited’

Next Article
"The License obtained is incompatible with the server" when starting an IMAGINiT Vault Server Utility
"The License obtained is incompatible with the server" when starting an IMAGINiT Vault Server Utility

If you receive a message 'The License obtained is incompatible with the server' when signing into an IMAGIN...