Vehicle Tracking: “Failed to retrieve a Vehicle tracking license [Error Code -3: User canceled authorization]”

June 20, 2025 Jeff Arbogast

Issue:
Vehicle Tracking: “Failed to retrieve a Vehicle tracking license [Error Code -3: User canceled authorization]”.


Causes:
Wrong License assigned or not assigned
Outdated SSO, Identity Manager, Licensing


Solution:

  • Go to https://manage.autodesk.com/uma/user-list/users
  • Find the User
  • Make sure they are assigned the correct software.
  • If they are make sure Vehicle Tracking has not been unchecked under the software group.
  • Select the Arrow to the right of the assignment.
  • Check Pop-up  (Make sure Vehicle Tracking is checked).

 
Figure 1

 


Figure 2

Install the updates for SSO, Identity Manager, and Licensing

Downloads:

Licensing
https://www.autodesk.com/support/technical/article/caas/tsarticles/ts/f5IhBc15i0kOwzBb8lcEN.html

Identity Manager
https://www.autodesk.com/support/technical/article/caas/tsarticles/ts/7zbgTemIhA3ltRs4eACL0g.html

SSO
https://www.autodesk.com/support/technical/article/caas/tsarticles/ts/A785RG35hP8oUR96WrYkn.html

  • Download all three.
  • Extract all files that have been zipped.
  • Go to each file and right click and select properties.
  • If you see a “Unblock” option place a check mark next to it.
  • Select OK.


Licensing
Right click run. This takes a bit to launch and does not ask for interaction so it can be a little odd.

If licensing does not run try to manually uninstall and then install again.
https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/How-to-uninstall-Autodesk-Desktop-Licensing-Service.html


Identity Manager
Right click and select run.

SSO

  • Right click and select run.
  • This one will ask you to uninstall or repair.
    Select Uninstall.
  • Then right click and run it again and let it install.


Now try testing Vehicle Tracking.

About the Author

Jeff Arbogast

Manufacturing Solution Center Team Lead<br><br>Jeff is responsible for manufacturing Technical Support for both internal staff and customers. In addition to the daily activities of the support center, he helps write for the National Support Center blog, and has written online classes for the IMAGINiT training on demand site.

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