AutoCAD: “Unrecognized version cannot be read”

June 18, 2025 Jeff Arbogast

Issue:
AutoCAD: “Unrecognized version cannot be read”


Causes:
Bad Install
Corrupted Support File

Solution:

  • Repair Visual C++ starting with Visual C++ 2012
    1. Access Apps & Features:
    Go to the Windows Start Menu.
    Click on "Settings" (the gear icon).
    Navigate to "Apps" and then "Apps & features". 
    2. Locate Visual C++ Redistributable:
    Scroll through the list of installed applications and find the entries that start with "Microsoft Visual C++".
    Look for versions like "Microsoft C++ <year> Redistributable <x86 and x64>". 
    3. Initiate Repair:
    Select the specific version of the Visual C++ Redistributable you want to repair.
    Click on "Modify".
    A dialog box will appear, offering options like "Repair" and "Uninstall".
    Click on "Repair".
    Follow the on-screen instructions to complete the repair process. 
    4. Repeat for other versions (if needed):
    Repeat steps 2 and 3 for all the versions of Visual C++ Redistributable that you want to repair.

  • Clean uninstall reinstall
    https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Clean-uninstall.html

Warning!
Problems caused by improperly editing the Windows Registry could render your computer operating system unusable. Microsoft provides a wealth of critical information that you need to know about the Registry in the Microsoft Knowledge Base . Use the Microsoft Registry Editor only at your own risk and only after backing up the Registry as outlined for your operating system in the Microsoft article How to back up and restore the Registry in Windows and in the related solution How to backup the system Registry . Additional information about the Registry is also contained in the Help topics in the Microsoft Registry Editor.

About the Author

Jeff Arbogast

Manufacturing Solution Center Team Lead<br><br>Jeff is responsible for manufacturing Technical Support for both internal staff and customers. In addition to the daily activities of the support center, he helps write for the National Support Center blog, and has written online classes for the IMAGINiT training on demand site.

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