Installing from Autodesk Desktop App: The Digital Signature needed for this install cannot be verified

April 30, 2021 Jeff Arbogast

Issue:

When installing from the Autodesk Desktop App you receive an error. “The Digital Signature needed for this install cannot be verified”.

Causes:

This is due to an incomplete download.

Solution:

 

Option 1

Download and install the latest Autodesk Desktop App and try again.

Autodesk Desktop App Clean Uninstall/ Reinstall

Autodesk Desktop App Install

 

Option 2

Installing using one of the other installation methods such as Download Now, Browser Download.

Go to www.autodesk.com

  • Login
  • Go to “Products and Services”
  • Find the software you wish the download
  • Select “View Downloads”
  • Select the version you want.
  • Select either Download Now or Browser Download.

 

If “Install now” is the current option. Select below the Install Now icon and select “View All”.

Select the Download type you want (Download Now or Browser Download)

Proceed with the download and install.

How to use

Browser Download

Download Now

 

About the Author

Jeff Arbogast

Manufacturing Solution Center Team Lead<br><br>Jeff is responsible for manufacturing Technical Support for both internal staff and customers. In addition to the daily activities of the support center, he helps write for the National Support Center blog, and has written online classes for the IMAGINiT training on demand site.

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