Issue:
Cannot download Autodesk software.
Causes:
There can be several problems including.
- Security.
- Slow Internet Connection.
- Browser Issues.
- Java Script.
- Pop-up Blockers, Cookies, Data Cache.
Solution:
How to resolve these issues.
- There are 3 methods for downloading software.
- Install Now (Performs an online install and can have security and speed issues).
- Download Now (Downloads the entire installer however it does use a Download Manager which can have issues with Security).
- Browser Download (Slower this is just downloading Multiple files that are Autodesks version of spanned zip files, This can have issues with Pop-up Blockers etc., because you may not be getting all of the files you need look for the count on the download file name such as 1of2 and you only have 1 file etc.).
https://www.autodesk.com/support/download-install/individuals/download/download-methods
https://resources.imaginit.com/installation/autodesk-download-manager-and-download-now-method
- If you have issues with the methods above you could try using AVA which is the Autodesk Virtual Agent.
- Use a wired connection rather than a WiFi. This can cause issues because the speed can very using WiFi.
- Enable Java Script.
- Disable Security (Temporarily) Virus Scan, Firewall, Port Blocking, VPN.
- Disable and Remove Pope Blockers, Cookies, Browser Cache.
- Try a different Browser.
- Close all additional Tabs in your Browser.
About the Author
Follow on Linkedin More Content by Jeff Arbogast