Revit: When launching you receive the message “Licensing System Error 2”

May 6, 2022 Jeff Arbogast

Issue:

Revit: When launching you receive the message “Licensing System Error 2”.

Causes:

  • Corrupted Loginstate.xml.
  • Missing Licensing SSO (Single Sign On) and Licensing updates.
  • Corrupted Visual C++ redistributed install.
  • Security.

Solution:

 

  • Reset licensing

https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/How-to-change-or-reset-licensing-on-your-Autodesk-software.html

Delete the file

C:\Users\<User login<\app data\local\Autodesk\Web Services\Loginstate.xml

Delete

C:\Users\user\AppData\Roaming\Autodesk\ADUT.

C:\program data\Autodesk\AUDT

  • Install updates for SSO and Licensing.

https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/simplecontent/content/autodesk-single-sign-component-update-for-2020-2021-product-versions.html

https://knowledge.autodesk.com/support/autocad/learn-explore/caas/sfdcarticles/sfdcarticles/Autodesk-Licensing-Service-Updates.html

  • Reinstall Visual C++ redistributed.

https://knowledge.autodesk.com/support/autocad/learn-explore/caas/sfdcarticles/sfdcarticles/How-to-reinstall-Microsoft-Visual-C-Runtime-Libraries-from-Autodesk-software-installation-package.html

  • Reinstall with all Virus scan disabled.
  • Make sure to install all updates for Revit.

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/downloads/content/autodesk-revit-2016-product-updates.html

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/downloads/content/autodesk-revit-2017-product-updates.html

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/downloads/content/autodesk-revit-2018-product-updates.html

https://knowledge.autodesk.com/support/revit-products/troubleshooting/caas/downloads/content/autodesk-revit-2019-product-updates.html

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2020/ENU/RevitReleaseNotes/files/RevitReleaseNotes-2020updates-html-html.html

https://knowledge.autodesk.com/support/revit-products/learn-explore/caas/CloudHelp/cloudhelp/2021/ENU/RevitReleaseNotes/files/RevitReleaseNotes-2021updates-html-html.html

https://knowledge.autodesk.com/support/revit-products/downloads/caas/downloads/content/autodesk-revit-2022-product-updates.html

About the Author

Jeff Arbogast

Manufacturing Solution Center Team Lead<br><br>Jeff is responsible for manufacturing Technical Support for both internal staff and customers. In addition to the daily activities of the support center, he helps write for the National Support Center blog, and has written online classes for the IMAGINiT training on demand site.

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