Issue:
Inventor is crashing in module KERNELBASE.dll with a dialog box like this:
Or Inventor is periodically locking up or crashing and faulting in module name Kernelbase.dll in the ‘Windows Error Reporting’ or ‘Windows Event Viewer Application logs’.
Causes:
The Microsoft Visual C++ runtime libraries and Inventor installation may be corrupt.
With Vault Client installed and running as an Add-In, the Vault installation may also be causing similar problems in Inventor.
Solution:
Check the Windows System Information ‘Windows Error Reporting’ or ‘Windows Event Viewer Application logs’ section for Kernelbase.dll errors.
- To open System Information:
In the Windows search box type in ‘System Information’.
- OR use the Windows logo key + R on keyboard to open the ‘Run’ dialog box.
- Type in ‘msinfo32’
- See the Windows Error Reporting section:
- To open Windows Event Viewer:
Windows Error Event Viewer Application Logs
Based on the presence of Kernelbase.dll errors in the Windows Error Reporting and Windows Event Viewer uninstall Microsoft C++ and Inventor.
- Remove and reinstall Microsoft C++ runtime libraries:
Uninstall and reinstall Microsoft C++ Libraries
- Clean uninstall Inventor or all Autodesk software
Go through the 'Inventor clean uninstall' or if Vault or other applications show errors in same module uninstall them all with the 'All Autodesk products clean uninstall'
All Autodesk products clean uninstall
See similar Kernelbase.dll errors in AutoCAD and Vault Client if the errors persist after reinstalling C++ and Inventor:
- AutoCAD Kernelbase.dll error
- Vault Client crashing with Kernelbase.dll and Connectivity.VaultPro.exe error in KERNELBASE.dll
- Tips on how to troubleshoot Inventor stability and crash issues
About the Author
More Content by Joanna Gryszka