AutoCAD: PUBLISH command causes AutoCAD to Freeze

November 27, 2024 Jeff Arbogast

Issue:
AutoCAD: PUBLISH command causes AutoCAD to Freeze When opening a file in Plant 3D.


Causes:
Unsupported Video Card or Driver.
Slow Drawing Access (Network, VPN, WiFi).
Plotting in Foreground or Background.
AutoCAD Updates.
Corrupted file.


Solution:

Unsupported Video Card or Driver
•    Go to www.autodesk.com\hardware
•    Select AutoCAD as the software
•    On the new page fill out the drop downs Operating System, Video Card Manufacturer, Version
The resulting list are all the tested and supported Video cards and Drivers (Driver download is to the right)

If your Video Card is not listed, then it is not tested and supported you can test various Drivers and Test disabling hardware acceleration. 

How to enable or disable hardware acceleration in AutoCAD

https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/How-to-enable-or-disable-hardware-acceleration-in-AutoCAD.html


Slow Drawing Access (Network, VPN, WiFi)
•    Test Network Speed, Disable any Syncing software such as (OneDrive, Drop Box, Sharpoint,etc).
•    Bring files locally and test on the local system in a User Created Folder.
•    Do not use WiFi use wired connections.


Plotting in Foreground or Background
•    Go to Option.
•    Go to the Plot and Publish tab.
•    Test Plotting use Plot in Background and Not Plot in Background.

You can also try 

Set system variable BGCOREPUBLISH to 0 (later versions this is on/off rather than 1/0)
This turns on and off the ability for Publish to use Multi Cores or 1 Core of a processor.
https://help.autodesk.com/view/ACD/2025/ENU/?guid=GUID-CEA83608-0AC0-4188-B413-DE586EBB103C

AutoCAD Updates
Make sure AutoCAD and is using a vertical all verticals are up to date.
•    Go to https://manage.autodesk.com/products
•    Login
•    Find your software
•    Select details
•    Select the version you are using
•    Select Updates tab.

Corrupted file
How to repair corrupt AutoCAD files
https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/AutoCAD-File-Corruption.html

About the Author

Jeff Arbogast

Manufacturing Solution Center Team Lead<br><br>Jeff is responsible for manufacturing Technical Support for both internal staff and customers. In addition to the daily activities of the support center, he helps write for the National Support Center blog, and has written online classes for the IMAGINiT training on demand site.

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