Vault Login Failure with IMAGINiT Vault Server Utilities

November 27, 2024 Heath White

Issue:
After applying the Vault 2025.1 or 2025.2 Client update, you receive an “Unhandled Exception when trying to log into the Imaginit Vault Server Utilities.

 

Causes:
This problem is due to changes, introduced by the Vault Client updates mentioned previously, to certain .dll files used by the Imaginit Utilities for connecting to the Vault.

Solution:
The recent Vault updates to 2025 have updated some of the .dll files that the Imaginit Server Utilities use to log into Vault. That is what causes the error shown previously.

To resolve the issue, you need to first ensure that the "IMAGINiT Job Processor Manager" is Stopped/NOT running.

 

Once the "IMAGINiT Job Processor Manager" has been stopped, you will need to navigate to the following location, "C:\Program Files (x86)\IMAGINiT Technologies\IMAGINiT Utilities for Vault Server", and run the "UpdateFiles.exe" as shown below.

 

If you forgot to stop the "IMAGINiT Job Processor Manager" or if you have any other of the Imaginit Server tools active, you will receive a screen similar to the one shown below:

 

If you have everything closed as indicated, then you should see a command prompt indicating a successful replacement of the affected .dll files as shown below.

 

Once the files have been successfully updated, you should be able to log back into the Vault via to Imaginit Server Utilities as usual. If you try these steps and are not able to resolve the issue, please contact us at support@rand.com and we’ll be happy to assist you.

About the Author

Heath White

Sr. Technical Support Specialist, Manufacturing

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