Vault sign in from Metadata Update tool causes Unhandled Exception

October 18, 2024 Bob Felton

Issue:

After installing the Vault 2025.1 Update for the Vault Client, the Vault Metadata Update from the  IMAGINiT Utilities for Vault Server 2025, will get an unhandled exception error when logging into Vault. Before the update, this error did not occur.

The error message context will also show this detail:

************** Exception Text **************
System.IO.FileNotFoundException: Could not load file or assembly 'DevExpress.Data.Desktop.v22.2, Version=22.2.7.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a' or one of its dependencies. The system cannot find the file specified.
File name: 'DevExpress.Data.Desktop.v22.2, Version=22.2.7.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a'

Causes:

The Vault 2025.1 Client update has placed new versions of the Autodesk and DevExpress DLLs in the Vault Client's folder that now have newer copies than the versions that work with the IMAGINiT Utilities for Vault Server 2025.

Solution:

Uninstall the Vault 2025.1 Update (Client) (but NOT the 2025.1 Update (Server), like this:

Note: If the Vault Server Utilities are installed under Windows 11, the 'View installed updates' will not list the Vault 2025.1 Update (Client) to uninstall, as shown above.

If you don't see the Vault 2025.1 Update (Client) to select to uninstall in Windows 10, that means the Update was included with the Vault 2025.1 Client download. If so, you must uninstall the Vault 2025 Client, and then reinstall it to exclude the 2025.1 Update.

If the Vault 2025.1 Update was installed after the Client then here is a silent uninstall script that can be run in an Admin cmd prompt from either Windows 10 or Windows 11 to remove the Vault 2025.1 Update (Client), based on details from this Autodesk Technical Article:

"C:\Program Files\Autodesk\AdODIS\V1\Installer.exe" -q -i uninstall --trigger_point system -m C:\ProgramData\Autodesk\ODIS\metadata\{54487C00-981E-3AAA-AEAD-8A471F210680}\bundleManifest.xml -x C:\ProgramData\Autodesk\ODIS\metadata\{54487C00-981E-3AAA-AEAD-8A471F210680}\SetupRes\manifest.xsd

Note: To confirm that the Vault 2025.1 Update (Client) was uninstalled, check for 'Build 30.0.91.0' in Help > About in the Client, like this:

 

After removing the 2025.1 Update, next shut down any running applications or services from the IMAGINiT Utilities for Vault Server.

For example:  Shut down the IMAGINiT Vault Job Manager that sends email notices if the Job Processor is stalled or not running.

Open up two side-by-side folders:

  • C:\Program Files\Autodesk\Vault Client 2025\Explorer
  • C:\Program Files (x86)\IMAGINiT Technologies\IMAGINiT Utilities for Vault Server

Copy the updated DLLs from the Vault 2025\Explorer folder into the IMAGINiT Utilities for Vault Server folder, like this:

Finally, download from this link, the DevExpress.Data.Desktop.v22.2.dll that is mentioned as missing in the error message. Extract the zip file from the Downloads folder to locate DevExpress.Data.Desktop.v22.2.dll. Its Properties will show as version 22.2.7.0 in Details from here:

Navigate to, or copy the path including quotes, and paste into Start > Run, this path:

 "C:\Windows\Microsoft.NET\assembly\GAC_MSIL\DevExpress.Data.Desktop.v22.2\v4.0_22.2.7.0__b88d1754d700e49a\"

Then from Downloads, Copy DevExpress.Data.Desktop.v22.2.dll and paste it into the folder at the path shown.

Restart the IMAGINiT Vault Job Manager in Services, if it was stopped earlier.

That should solve the unhandled exception so the Vault Metadata Update can successfully sign in to the Vault server. This will also work for these other Vault Server Utilities that require the Vault Client to sign into Vault for them.

    • Related Files Checker
    • Vault Change Summary
    • Vault Config Export
    • Vault Metadata Update
    • Vault Security Tool

 

Note: A future update for the Vault Server Utilities should provide a one-button approach to this for the next time the Vault Client update installs newer dlls.

About the Author

Bob Felton

Sr. Technical Support Specialist, Manufacturing<br><br>Bob Felton has been supporting Autodesk products for over 25 years including core AutoCAD, P&ID, Plant 3D, AutoCAD for Mac, AutoCAD Mechanical, and Vault. His background is in graphics with an Applied Sciences degree and ten years manufacturing experience drafting, as well as technical illustration, image editing, and even patent drafting.

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