Issue:
When using the IMAGINiT Vault Client Utilities to 'Create PDF', the Vault Job Queue (under Tools > Job Queue in the Vault Client) might show this message: "The console path location could not be determined! Please specify it in the configuration file.", in this context:
Causes:
This typically occurs when AutoCAD is not installed on the same host as the Job Processor. In this context, the 'console path' refers to the accoreconsole.exe for AutoCAD located here:
C:\Program Files\Autodesk\AutoCAD 2022\accoreconsole.exe, for AutoCAD 2022 and similar for other versions.
Solution:
To correct this, install AutoCAD to match the version that connects to Vault and open it at least once. Once initialized, it will only need an AutoCAD license to continue serving the Job Processor, without AutoCAD running.
If that still doesn't clear the Job Queue error, that means that the default settings are not finding AutoCAD correctly.
To correct that, locate and open the config file 'IMAGINiT.VaultJobs.dll.config' in Notepad from here:
C:\ProgramData\Autodesk\Vault 2022\Extensions\IMAGINiT.VaultJobs\IMAGINiT.VaultJobs.dll.config (for Vault 2022 - other versions are similar.)
In this config file, search for AcCoreConsoleLocation and then copy and paste this into the config file:
<add key="AcCoreConsoleLocation" value="C:\Program Files\Autodesk\AutoCAD 2022"/>
in place of
<add key="AcCoreConsoleLocation" value="Auto"/>
Like this:
Once saved in Notepad, then log out of Vault in the Vault client, and exit the Job Processor. Then log back into Vault and start the Job Processor again and test the PDF Create job once again.
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