Revit Quick Exits after using IMAGINiT Utilities for Revit Tool

February 11, 2022 Jeff Lotan

Revit Quick Exits after using IMAGINiT Utilities for Revit Tool

Issue:

Revit Quick Exits after using IMAGINiT Utilities for Revit add-in/add-on Tool

Cause:

This can happen due to a conflicting add-on tool in Revit.

Solution:

To narrow down if the problem is with the IMAGINiT Utilities for Revit or another add-on, disable all add-ons except the Utilities for Revit and test.  If it does not crash Revit, then it should be an easy fix.

 

During testing I recommend using a blank new project.

 

You can use one of the methods below to disable the add-ons to find out which one is conflicting.  The either re-enable them and it may work fine.  If not, then uninstall/reinstall the conflicting add-on. 

 

Manually disable add-ons

Note: If working with cloud models, see the info below on add-ons to keep loaded!

1.    Close all versions of Revit.

2.    Locate the following folder: C:\ProgramData\Autodesk\Revit\Addins\[Version]

3.    Temporarily move the add-on files from the folder above to another location.

4.    Launch Revit. Add-ons will be disabled.

 

Alternate locations that add-ons could be loaded from:

Add-ons that load into multiple products/versions:

•    C:\ProgramData\Autodesk\ApplicationPlugins.

Add-ons loaded for only one user (less common):

•    C:\%USERPROFILE%\AppData\Roaming\Autodesk\Revit\Addins\[Version]

•    C:\%USERPROFILE%\AppData\Roaming\Autodesk\ApplicationPlugins

 

Cloud Models

If working with models stored on the cloud (BIM 360 Document Management or Autodesk Docs), keep the following Revit cloud components in the add-ons folder (while removing the others):

•    Autodesk.Collaborate.addin

•    ExportViewSelectorApp.addin

•    ExportViewSelectorAddin (Folder)

 

3rd party tool to enable/disable add-ons

If that does not remove the add-ons, then these 3rd party apps may help:

https://resources.imaginit.com/support-blog/revit-add-in-manager

 

https://knowledge.autodesk.com/support/revit/learn-explore/caas/sfdcarticles/sfdcarticles/How-to-Disable-Add-Ins-for-Revit-Products.html

 

There was one case reinstalling Enscape resolved it.

 

Created by Jeff Lotan - IMAGINiT Technologies Technical Support

 

 

About the Author

Jeff Lotan

Sr. Technical Support Specialist - Licensing<br><br>I am charged with mentoring and training team members in the proper use our systems and tools, documenting NSC processes, and providing feedback and ideas to the management team towards improving the customer experience. I am also a major contributor to our technical support blog and internal knowledge base.

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