Opening a BIM 360 or BIM CONSTRUCTION CLOUD model with Revit: Error: Data file is corrupt

September 16, 2021 Bruce Boutin

Issue:

When trying to open a cloud Revit model, the following message is seen for only one user:

Open Model

Data in <file name>.rvt is corrupt and needs to be manually recovered.

 

Causes:

·       Corrupt Cache.

·       Not enough space to write to hard drive.

·       Conflicting Add-in

Solution:

Quick and dirty: Delete Local Copy and Download a fresh copy.  

Follow the Part A and Part B steps below.

Part A: Most Autodesk software issues involving excessive or corrupt temp files can be resolved by deleting the contents of a user's local temp folder. To do this:

  1. Exit all programs.
  2. Windows 10:

Just copy and paste the string below into the Windows search bar next to the and press <ENTER>.

  1. Delete the contents of the folder that opens up.

In each direct us <ctrl> + <a> to select all the folders and files and then press the <delete> key.

Do this for all three (3) directories (folders) listed below.

 

%USERPROFILE%\AppData\Local\Temp

C:\Windows\Temp

C:\Temp

Note, if you get this “Folder In Use” dialog box as illustrated below, follow the instructions in the illustration below.

 

Part B: Clear the corrupt/damaged cloud workshared model or outdated link from the system:

1.     Create a folder called Cache on the Desktop.

2.     Create a folder called Collab and Pac inside the Cache folder on the desktop.

3.     Move (DO NOT COPY) the contents of the “CollaborationCache” and “PacCache” folders to the corresponding folders created on the desktop.

1.       “CollaborationCache” folder location:

%USERPROFILE%\AppData\Local\Autodesk\Revit\

(It will look something like the illustration below)

  • Then go into the Revit version you are work with:
    1. Autodesk Revit ####\CollaborationCache

 

 

  1. Go to the folder called Cache on the Desktop and Paste (Move) the folder inside “CollaborationCache” into it

 

1.       “PacCache” folder location:

%USERPROFILE%\AppData\Local\Autodesk\Revit\PacCache

·       Note: Do not move the Logs folder or the .json file.

5.     Once the Folders have been moved. Open the version of Revit you are working with and open the problematic file in Revit.

·       Note: This will recreate the cache and clear any corrupt/damaged cloud workshared cache data.

6.     Open the Desktop folders from Step 3 and the original folder location of the Cache files.

7.     Move the files that were not recreated back into the original Cache folders.​​​​​​

·       Note: If none of the files are moved back into the original cache folders, the cache for other projects will need to be recreated which will slow down the initial time it takes to open the file.

Alternate approach, if you have access to a second system:

1.     On the second system, open Revit.

2.     Sign into your own A360 account.

3.     Open the problematic model.

4.     Copy the newly created CollaborationCache files from the second system to the original system (overwriting).

·       Note: All Cache files need to be copied. 

Alternate things to check if the issues are unresolved:

Check for Revit updates

·       Compare the version of Revit on the affected system compared to the versions used by other users. If these are different try matching the Revit versions (so that everyone is on the same build) and retry. See the following help topic for information on how to Update your software.

Free disk space

If the system runs out of disk space Revit can report corruption as it tries to access incomplete data in the temp folder. Make sure that there is enough disk space free on the system.

For info on how much space is required see the article Required hard disk space for Revit cloud worksharing models
 

The following Microsoft support page has info on using the Desk cleanup utility: Disk cleanup in Windows 10.

Clear local cache

Use the instructions in the following two articles to clear the Windows temporary files and the cloud collaboration cache for the model:

·       How to delete temporary files in Windows

·       How to clear a corrupt/damaged cloud workshared model or outdated link from the system in Revit

 

Disable add-ins

Use the instructions from the following article to disable Revit add-ins (keeping the cloud add-ins enabled):

·       How to disable add-ins for Revit

Multiple users affected

If it turns out that multiple users are affected, see the following article for troubleshooting options: "Data in file (file name).rvt is corrupt and needs to be manually recovered" when opening a file or syncing a file to central in Revit

 

Autodesk Knowledge Reference Link:

https://knowledge.autodesk.com/support/revit/troubleshooting/caas/sfdcarticles/sfdcarticles/Collaboration-for-Revit-The-data-in-file-name-is-corrupt-and-needs-to-be-manually-recovered.html

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