Issue:
Saving edits to a custom Content Center family in Vault results in a ‘Failed to publish to the selected library.’ error:
Causes:
The error can be caused by several known issues. Some can be resolved by installing the latest Vault updates and following the update Read Me to ensure they’re installed.
If the Vault updates don’t get rid of the error, there are some workarounds available:
- Vault 2022-issue reported with Incident ID:58270
- Vault 2020-2022-resolved with updates
- Vault 2020-resolved in Vault 2020.3.3 Update
Solution:
First install all Inventor and Vault updates.
1. Try detaching the library from Vault and reattaching it per the workaround here.
- Right-click on the custom Content Center library in Vault and select Detach…
- Once the library is detached, attach it again by right-clicking on Libraries and selecting Attach Library…. Choose to the library you just detached to re-attach it.
2. Transfer the Content Center library from Vault to Desktop Content and test saving changes to the library.
- Once the library is transferred change the Content Center library access to Inventor Desktop Content in Application Options.
- Test saving your Content Center library edits to the Desktop Content.
3. If edits are successful transfer your custom Content Center Library from Inventor Desktop Content to Vault.
- Delete the library from Vault before transferring from Desktop Content to Vault.
- Test saving your Content Center family edits to the Vault Content Center.
4. If the error persists consider using Desktop Content instead of Vault libraries.
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If sharing Desktop Content on the network library permissions are managed through Windows network file permissions.
For more help troubleshooting the error contact Imaginit Support or email support@rand.com.
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