Version: Revit 2023 and later.
Issue:
Revit fails to initialize the add-in when launching, displaying the following message repeatedly multiple times:
"Failed to initialize the add-in [add-in name] because the assembly [path to DLL] does not exist."
The path to the DLL points to a non-existing drive or a custom drive where it was previously installed. Even after a clean uninstall and re-installation of Revit, the issue persists.
Causes:
This issue arises from a previous Revit installation with custom settings. If the reinstallation of Revit is set to a different drive from the one used for the previous installation, a clean uninstall may not resolve the issue. Following the instructions on the links below does not resolve the issue either:
- "Failed to initialize the add-in [add-in name] because the assembly [path to DLL] does not exist" when launching Revit (autodesk.com)
- 2023: How to Complete a Clean Uninstall of Revit products (autodesk.com)
Solution:
To resolve the issue during the clean uninstall process, additional steps are required.
- Use the Microsoft Uninstallation troubleshooter tool to ensure the removal of all relevant Revit support tools, including schemas, material libraries, texture packages, and add-ins. Note that you may need to run the Microsoft Uninstallation tool multiple times as it only removes one software at a time.
- After completing the removal of the specific Revit version and all associated tools, navigate to the following folder locations and delete them:
- C:\Program Files\Autodesk\Revit [Version]
- C:\ProgramData\Autodesk\RVT [Version]
- C:\ProgramData\Autodesk\Revit\Addins[Version]
- C:\Users%USERNAME%\AppData\Local\Autodesk\Revit\Autodesk Revit [Version]
- C:\Users%USERNAME%\AppData\Roaming\Autodesk\Revit\Autodesk Revit [Version]
- Follow the remaining steps outlined in the guide "2023: How to Complete a Clean Uninstall of Revit products (autodesk.com)" to complete the uninstallation process.
- Download the new Revit installation package from the Autodesk Product page under your account.
- Reinstall Revit and apply the latest update to complete the installation process.
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