DGN Attach or Import fails with message cannot find DLL

November 12, 2021 Ryan Wunderlich

Issue:

DGN import/attach gives this error: C:\Program Files\Autodesk\AutoCAD 2020\acdgnio.dbx cannot find a dll or other file that it needs.

Or it gives this error:

Causes:

This problem is generally caused by an issue with an underlying set of programming or the AutoCAD settings have become corrupted.

Solution:

If the issue is only on one or two machines, then generally what I have found to correct the issue is to rebuild the C++ libraries:

https://resources.imaginit.com/support-blog/how-to-uninstall-and-reinstall-c-libraries

If that doesn’t correct the issue, then you will need to reset the settings back to the defaults and retest:

https://knowledge.autodesk.com/support/autocad/learn-explore/caas/sfdcarticles/sfdcarticles/How-to-reset-AutoCAD-to-defaults.html

About the Author

Ryan Wunderlich

Sr. Technical Support Specialist<br><br>An AutoCAD Certified Professional, Ryan is responsible for taking client cases and assisting with issues with the software - everything from regular glitches to software deployments and whatever else goes wrong. He's proficient in AutoCAD (including customization), VBA, LISP, and Civil 3D.

Follow on Linkedin More Content by Ryan Wunderlich
Previous Article
Attaching a PDF fails with an Error Message
Attaching a PDF fails with an Error Message

This problem is generally caused by an issue with an underlying set of programming or or the AutoCAD settin...

Next Article
Utilities for Revit 2022 How to use the Renumber From Corresponding Rooms on Another Level
Utilities for Revit 2022 How to use the Renumber From Corresponding Rooms on Another Level

In this guide we’ll be using a sample file that is installed with Revit and show you how to use the Room Re...

Need tech support? Let us help!

Learn More