ACC: Slow Performance on Mobile App? Check Device Cover

December 30, 2025 Jeremy Smith

Issue:
When attempting to use the ACC Mobile App in the field to access files, fill out forms, upload photos, etc., users report that the performance is slow or unresponsive despite having a good connection, and having plenty of available space and memory on their device.

Cause:
Certain protective covers for mobile devices, such as iPads can negatively affect performance of the ACC app (along with other applications), through either heat retention, magnetic interference, or both.

Heat Retention

        • Many cases designed to protect iPads and other devices on a construction site are made with materials like silicone or hard plastic.  In some cases, these trap heat against the device.
        • To protect itself, the device will initiate "thermal throttling" which will slow down the processor to lower the temperature.  This will cause lagging or freezing when viewing/panning large files on ACC, uploading new files, or syncing project data.

Magnetic Interference

        • Folio or folding style device cases that contain strong magnets that keep the protective case closed when not in use could interfere with the internal sensors in the iPad or other device.
        • This can produce behavior such as latency when using the markup tools or affecting accuracy when taking and attaching photos to issues in Build.

Solution:
To determine whether the protective case is a factor in the poor performance, remove the case and test the device without it to see if the performance improves.

If the behavior and performance improve without the cover, it may be better to remove the case during intensive or extended use, or you may need to opt for a case with better ventilation and/or heat-conducting materials.

About the Author

Jeremy Smith

Sr. Technical Support Specialist, AEC<br><br>Jeremy has been delivering service and technical support to customers in the AEC industry for over 25 years. He gained much of his AutoCAD/Revit experience serving as CAD Manager at multiple MEP/FP engineering firms in the Greater Boston Area. He then worked at Autodesk as a Technical Support Specialist, eventually becoming a manager overseeing the Revit and Vault support teams. Jeremy is excited to be in his current role as Sr. Technical Support Specialist at IMAGINiT, as it allows him the opportunity to work directly with customers every day and help them successfully leverage Autodesk’s solutions to achieve their business goals.

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