Vault Professional Check In Error: "You do not have adequate permissions to perform this operation".

August 25, 2021 Heath White

Issue:

You are attempting to check in a file or files checked  checked out to you, which you have also updated and saved without issue.  When you do so, you receive the following error:

Causes:

This issue is due to permissions restrictions as indicated in the error message above.  However, this issue can be difficult to track down since the message contains no useful information regarding exactly which permissions/settings may be preventing the process from completing successfully.

 

While there are multiple potential configuration settings that could lead to this situation, this article will address the cause that is most common when migrating files from one release of Inventor to another using the Administrator account.

 

If we look at the file status in Inventor, the file is checked out to the user and has been saved successfully, however when checking the file in, the error will pop up.   I have made this example with the default Administrator account.

 

Below you can see that the file is in a “Released” state, which is not normally an editable state.  For this example, we want to migrate the file format to the latest Inventor file format as part of a regular migration between software releases. This type of change does not warrant a revision bump since form, fit, and function are not affected by the change in file format.  To that end, we often give the Administrator or an equivalent account the ability to edit “Released” files or the ability to use a “Quick Change” state for the same purpose.

Note the security settings for the Lifecycle as shown below:

 

When checking security on the file itself you can see that the Administrator has explicit permission to “Modify” the file.

 

Solution:

The clue that leads us to the solution can typically be found in two places, as shown below.

 

In Inventor:

 

In Vault Pro Client:

 

The areas indicated show that the file is associated with an “Item”.  Within the view inside of Inventor, you also can see that the Item is locked.  That indicates that the Item has security associated with it and that is where we need to look next for the root cause of our issue.

 

As you can see in the Item Master, the file is showing as locked even though the Administrator is the user that is logged in.

 

This indicates that the Administrator account does not have permission to edit the Item that is associated to the file.  If we look at the security for this Item, we can see that the “Everyone” group is the only User/Group that is listed.  This Group only has “Read” and “Download” permissions.  Both “Modify” and “Delete” permissions are set to what is referred to as a “Soft Deny”, meaning that unless a User/Group has explicit “Allow” permissions, then they will be denied that action.

 

Since even the Administrator is part of the “Everyone” group the restrictions apply to the Administrator as well.  We can verify this by checking the Effective Access as shown below.

 

Now that we know what is preventing our ability to check the file(s) into Vault, we can edit the Item Lifecycle to allow the Administrator to have the proper permissions.

 

 You can see above that the Administrator account has been added to the security settings for the “Published to ERP” Item Lifecycle State.  The Administrator account has also been given the permission to modify Items while they are in that state.

 

Note: Please keep in mind that the process being illustrated in this article is just an example used to show a specific problem and its suggested solution and should not be taken as a recommendation for how you should or should not set up your own lifecycles and security settings.

After giving the Administrator the necessary permissions, you’ll notice that the Lock no longer shows on the Item.  This indicates that the Administrator now has the ability to modify the Item and will no longer be denied permission to do so.

 

As you can see below, going back to Inventor, the Check In process now proceeds without any errors so the file(s) can be migrated to the latest format. 

 

Hopefully this solution will be of benefit to you and save you both time and frustration.  As always if you need assistance with your Vault, please reach out to us here at Imaginit.

About the Author

Heath White

Sr. Technical Support Specialist, Manufacturing

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