Issue:
User tries to make changes to an ECO, but receives the following error message even though they should be able to make edits to the ECO:
Causes:
Typically, this issue is due to the user not being assigned the correct role in the ECO routing list. However, the case that caused me to author this article was different. In this instance, the reason the users (all users, regardless of role, including the ECO creator) were unable to make changes to the ECO was because the routing used to create the ECO had been deleted at some point in the past, although no one knew when or why.
Comparing the specified Routing List to the available Routing Lists showed the specified list no longer existed and any ECO specifying that Routing would return the indicated error, while ECOs that utilized different Routing Lists worked as expected.
Solution:
In this case, due to the fact that there were only a small number of ECOs that made use of the deleted Routing, the client chose to just switch the Routing that was missing for a different Routing that they used for other ECOs. This is done by editing the ECO, choosing the “Edit” option in the lower left corner of the ECO window, and choosing the preferred Routing from the list of available Routings.
After choosing the new Routing List, you will receive the following prompt.
If the number of ECOs that are using the deleted Routing List is too large to consider manually changing the Routing for each ECO, then you may want to attempt to recreate a Routing with the same name as the missing Routing. We did not attempt this when troubleshooting this scenario so it is possible that recreating the Routing may not work in your environment, but it would be worth exploring as an option.
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