The AutoCAD process did not create the output file for IMAGINIT.PDFCREATOR Job

September 6, 2024 Bob Felton

Issue:

When generating a PDF from an AutoCAD dwg file using the IMAGINiT Utilities for Vault Client, either manually from the right-click menu or as an action for a transition in a Lifecycle definition, such as between Work in Progress to Released states, the IMAGINIT.PDFCREATOR job may report an error in the Vault Job Processor queue.

From the results in the bottom right corner, if you click, then drag down to select the entire error, it will show more details similar to this example:

Parameters: ;    FileId=757011;NOTE: ClarityPDF is not installed (but should no longer be necessary);Retrieving appropriate files for: FILE Id=757011;Processing 1 file(s)...;File: C:\Users\<username>\AppData\Local\Temp\21801-N100-N200.dwg already exists - will delete.;Acquired 1 file(s)...;  - C:\Users\<username>\AppData\Local\Temp\21801-N100-N200.dwg version: 4;       (PRIMARY FILE);Downloaded file: 21801-N100-N200.dwg Version: 4 State: Work in Progress;Target PDF format: [OriginalFileName] [Date].pdf;Target PDF name: 21801-N100-N200 2024-08-28.pdf;Exception during PrintFile: ApplicationException: The AutoCAD process did not create the output file: C:\Users\<username>\AppDataLocal\Temp\21801-N100-N200 2024-08-28.pdf;Retrying, count=1;Exception during PrintFile: ApplicationException: The AutoCAD process did not create the output file: C:\Users\<username>\AppData\Local\Temp\21801-N100-N200 2024-08-28.pdf;Max # of retries exceeded.;Error: ApplicationException: The AutoCAD process did not create the output file: C:\Users\<username>\AppData\Local\Temp\21801-N100-N200 2024-08-28.pdf

Causes:

The error message "Autodesk The AutoCAD process did not create the output file" indicates that when attempting to export or generate a file from AutoCAD, the process failed to produce the expected output file, likely due to issues with the file path, permissions, corrupted data within the drawing, or problems with the export settings themselves.

Solution:

  • Check that AutoCAD is installed and matches the same product year as the Vault Client on the Job processor host - Vault Pro 2024 and AutoCAD 2024, for example.
  • Open AutoCAD to ensure it initializes and creates the registry and user entries needed for Vault to call it to produce a PDF.
  • With AutoCAD open, locate and load the drawing mentioned in the error to see if it can plot to a PDF driver such as DWG to PDF.pc3. 
  • Also, check if the AutoCAD dwg file mentioned in the error details is not open in AutoCAD. If it is, close the drawing, check it in if prompted, then resubmit the IMAGINIT.PDFCREATOR job again.

About the Author

Bob Felton

Sr. Technical Support Specialist, Manufacturing<br><br>Bob Felton has been supporting Autodesk products for over 25 years including core AutoCAD, P&ID, Plant 3D, AutoCAD for Mac, AutoCAD Mechanical, and Vault. His background is in graphics with an Applied Sciences degree and ten years manufacturing experience drafting, as well as technical illustration, image editing, and even patent drafting.

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