Network Licensing Error “An incompatible version…”

September 30, 2024 Shawn Heator

Issue:

After installing the latest Autodesk Licensing Service or new version(year) of Autodesk application, your Autodesk applications, utilizing a Multi-user (Network) license, experience a licensing error. The error will show “An incompatible version of the Autodesk network license manager is installed on the server.” and may reference error 0,0,0 or  -83. See the example images below

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Causes:

The problem is caused by incompatibility with a new version of the Autodesk License Service, on the user computer, and the version of the Autodesk Network License Manager (LMTOOLS) on the server. As shown in the image below, the Network Licensing Manager (LMTOOLS) needs to be upgraded to v11.18 (or newer) if the Autodesk Licensing Service version 12.2.0.17 or higher is installed on user computers.

This issue effects Autodesk 2020 and higher applications. LMTOOLS needs to be v11.18 or this issue will occur. The error does not occur with the updated v11.18 version depicted in the image below. To check your version of LMTOOLS, log into the server and launch LMTOOLS. Go to Help>About to view the version of LMTOOLS.

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Solution:

There are two methods to resolve the licensing problem between the user computer and the version of LMTOOLS on the server: Either upgrade the version of LMTOOLS to v11.18 or higher (current version is v11.19) or rollback the latest Autodesk Licensing Service to a previous version. 

*Note: The most current versions of Autodesk applications require v11.19 LMTOOLS to obtain a license.*

Option 1: Follow the steps below to upgrade LMTOOLS to a newer version.

  1. Open LMTOOLS and go to the Start/Stop/Reread tab to select the "Force server shutdown" box and then select Stop Server. Close LMTOOLS.

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  1. Open Control Panel>Programs and Features>Uninstall a program. Select Autodesk Network License Manager and Uninstall.Graphical user interface, text, application

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  2. Download and install the latest version of LMTOOLS from the link below.
    https://knowledge.autodesk.com/customer-service/network-license-administration/get-ready-network-license/download-the-network-license-manager
  3. Open LMTOOLS and go to the Config Services tab. Select "Browse" next to "Path to the lmgrd.exe" and select the lmgrd.exe. Default location is C:\Autodesk\Network license manager. Select Open and then Save Service.Graphical user interface, text, application

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  4. Go to the Start/Stop/Reread tab and select Start Server.       

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The Autodesk Network License Manager (LMTOOLS) is now upgraded to the latest version.

 

Option 2: Follow the steps below to rollback your Autodesk Licensing Service to a previous version. 

  1. Open File Explorer and navigate to the path below.

C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing

  1. Right click on uninstall.exe to Run as Administrator.

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  1. Use the link below to download the older version of the Autodesk Licensing Service 12.1.0.7121.

https://up.autodesk.com/2023/PLC0000036/1744A277-0A59-3663-BCA4-B2FEB41FE668//AdskLicensing-installer.exe

  1. Right click on the downloaded file (AdskLicensing-installer.exe) and go to Properties. Check the box for "Unblock" if it appears. Select OK to close the dialog box.

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  1. Right click on AdskLicensing-installer.exe to "Run as Administrator”.

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The installer window may take several seconds to appear on your screen. It will then install the AdskLicensingService.exe and close without any user prompts required. Autodesk software should open without any network licensing errors.

About the Author

Shawn Heator

Technical Support Specialist

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