Issue:
An error appears when launching Autodesk Vault Client 2020 or 2021 that states “Error: Object reference no set to an instance of an object”. The problem occurs for all versions of Vault Client (Basic, Workgroup, and Professional) that are from 2020 or 2021. Vault Clients for 2022 or 2023 are not affected.
This error occurs before the Vault login dialog box appears and you are not able to log into Vault.
Causes:
The problem is related to the bin folder located in the user profile path below.
C:\Users\%username%\AppData\Roaming\Autodesk\ADPSDK\bin
Solution:
Rename the bin folder.
- Open File Explorer.
- Copy and paste the path below into File Explorer.
C:\Users\%username%\AppData\Roaming\Autodesk\ADPSDK
- Find the bin folder. Rename the folder to bin_old.
- Launch the Vault Client and the normal Vault login dialog box should appear. The software should continue to function as expected.
**If the problem returns then it may be necessary to rename the ADPSDK folder to ADPSDK_old, one folder above the bin folder, to resolve the problem.
Additional references: https://knowledge.autodesk.com/support/vault-products/troubleshooting/caas/sfdcarticles/sfdcarticles/Object-reference-not-set-to-an-instance-of-an-object-when-trying-to-log-in-to-Vault-after-Fusion-360-installation.html
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