Autodesk licensing error ‘the license you’re using is not valid’ or ‘Your access to <product-name> is now limited’

April 7, 2022 Joanna Gryszka

Issue:

Your Autodesk product runs but you get an error that ‘The license you’re using is not valid’ or ‘Your access to <product-name> is now limited’.

These are example errors you might get:

Causes:

See the reference Autodesk article:

https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/The-license-you-re-using-is-not-valid.html

Solution:

  1. If present, uninstall A360 from Windows Control Panel. Restart the computer.
  2. Install the latest Autodesk licensing and single sign-on updates:

Autodesk Single Sign On (AdSSO)

Uninstall the current ‘Autodesk Single Sign On Component’ from Control Panel and install the latest from the link above.

Autodesk Licensing Updates

Uninstall the ‘Autodesk Licensing Service’ by running this file C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing\Uninstall.exe

When the folder is empty install the latest licensing service.

3. Reset the licensing and local login cache to force a reactivation.

Reset login cache

  1. For 2019 and older delete this file
    • %localappdata%\Autodesk\Web Services\LoginState.xml
  2. For 2020 and newer run the Login Reset Tool or do the following:
    • In the Windows Task Manager on the Details tab stop these processes if running
      • AdSSO.exe
      • AdAppMgrSvc.exe
      • AutodeskDesktopApp.exe
      • AdskLicensingAgent.exe
      • ADPClientService.exe
    • Delete this file %localappdata%\Autodesk\Web Services\LoginState.xml

Reset licensing

  1. For 2020 and newer:
  2. For 2019 and older delete these files/folders if present
    1. %appdata%\AppData\Roaming\Autodesk\ADUT delete ADUT
    2. C:\ProgramData\FLEXnet and delete all files that start with adskflex
    3. Run the Imaginit Autodesk_License_Reset batch file to reset all your products to Single-User

 

If the steps above don’t resolve the problem typically a clean uninstall of all Autodesk products will.

Delete these folders once all the Autodesk products are uninstalled

  • C:\Program Files\Autodesk
  • C:\Program Files\Common Files\Autodesk Shared
  • C:\Program Files (x86)\Autodesk
  • C:\Program Files (x86)\Common Files\Autodesk Shared
  • C:\ProgramData\Autodesk
  • %localappdata%\Autodesk
  • %appdata%\Autodesk

Delete these registry folders(type regedit after clicking on the Windows Start button> select Registry Editor)

  • HKEY_CURRENT_USER\Software\Autodesk
  • HKEY_LOCAL_MACHINE\Software\Autodesk

About the Author

Joanna Gryszka

Manufacturing Technical Support Specialist<br><br>Joanna has over eight years of experience working with Autodesk products. She started supporting core AutoCAD and network installations of all Autodesk products. She now has five years of experience with Inventor. <br> She graduated from Mechanical Engineering and has been providing solutions to clients and dedicating her knowledge to the Solution Center since then.

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