Issue:
When trying to invite users to an Autodesk Account, the following error message is displayed, "Users weren't added due to network problems. Users weren’t assigned."
This is followed by a list of the user(s) who weren’t added.
Causes:
This error, often happens when the user is probably already added to the account, but as a guest.
When users are added to your ACC/BIM360 account hub, they are also added as guests to your Autodesk Account.
Solution:
To see the user(s) in your Autodesk Account, you have to toggle on "Show Guests" under User Management>>By User.
To change their role, go to User Management>>By User, select the user, and then change their role to User.
Alternatively, remove and re-add the user(s) to resolve the issue.
You may also refer to this Autodesk article for additional help - "Users weren't added due to network problems" when inviting users