Revit Error Revitworker.exe

August 11, 2023 Heather Volk

Issue:
Does this error pop up when launching Revit? 

Or does Revit fail to open, and this image pop up?


 

Causes:
1.    The Revitworker.exe is set to “Run this program as administrator.”
2.    Windows issues including:
•    Missing or pending Windows updates
•    Permissions issues
•    Corrupted Windows Management Instrumentation service (WMI). 


 

Solutions:
If the Revitworker.exe is running as administrator but the Revit process is not, it will cause issues with communication between the two. To test if this is happening, follow these steps:
1.    Right click on the Revit icon from the Windows Start menu or from the Desktop icon. 
2.    Select “Run as Administrator” 
*Note: if you are not an admin with admin rights, you will need to get your IT support to assist*

3.    If Revit launches normally and the error is gone then it proves that the Revitworker is running as admin. 
*Note: if the steps above (#1-3) do not fix the issue, please follow steps below to fix the Revitworker. 


 

Revitworker Fix:
Once you have confirmed that the Revitworker is running as admin, the following steps will fix the issues.
1.    Go to the Revit install directory located: C:\Program Files\Autodesk\Revit 20xx. 
2.    Right click on the Revitworker.exe and select “Properties.”
3.    Click on the “Compatibility” tab.
4.    Clear the “compatibility mode” and the “Run this program as an administrator.” Click “Apply” and then “Ok.”

5.    Start Revit normally (not set with “Run as admin”).


 

Windows Issues:
•    Go to search bar on task bar:

•    Type in “system info” and hit enter.
•    If the WMI is blank and states “Can’t Collect Information,” the computer has a windows issue. 


 

Windows (WMI) Fix:
1.    Open a blank Notepad and add the following:
@echo on
cd /d c:\temp
if not exist %windir%\system32\wbem goto TryInstall
cd /d %windir%\system32\wbem
net stop winmgmt
winmgmt /kill
if exist Rep_bak rd Rep_bak /s /q
rename Repository Rep_bak
for %%i in (*.dll) do RegSvr32 -s %%i
for %%i in (*.exe) do call :FixSrv %%i
for %%i in (*.mof,*.mfl) do Mofcomp %%i
net start winmgmt
goto End

:FixSrv
if /I (%1) == (wbemcntl.exe) goto SkipSrv
if /I (%1) == (wbemtest.exe) goto SkipSrv
if /I (%1) == (mofcomp.exe) goto SkipSrv
%1 /Regserver
:SkipSrv
goto End
:TryInstall
if not exist wmicore.exe goto End
wmicore /s
net start winmgmt
:End


2.    Save the document as “WBEM_Fix.bat” in the C:\Autodesk folder. 
3.    Right click the BAT file and Run as Administrator.
4.    A command prompt will appear and will perform several steps, let it run and do not close. Once it is done it will close on its own. 
5.    Reboot machine.
6.    Start Revit again. 


 

Windows Missing Important Updates Message Fix:
If your windows updates page says “Your device is missing important security and quality fixes” updates will need to be processed to get that error to go away. Go to the Windows search bar and type in “check for updates” and hit enter. 

1.    Click on “Check for updates.”
2.    Let any updates that come up process.
3.    If it needs to reboot, reboot when all items say, “Pending Reboot.”
4.    Once the computer reboots, go back into the windows updates and run the “Check for updates” until the message “Your device is missing important security and quality fixes” goes away. 


 

Permissions issues:
•    Full folder control should be set for all “Users” on the C:\Users\Public\Public Documents\Autodesk folder. 
•    Full folder control should be set for all “Users” on the following registry key KEY_LOCAL_MACHINE\SOFTWARE\Autodesk. 
•    More information on this click here. 

Warning! Problems caused by improperly editing the Windows registry could render your computer/operating system unusable. Microsoft provides a wealth of critical information that you need to know about the registry in the Microsoft Knowledge Base.  Use the Microsoft® Registry Editor only at your own risk and only after backing up the registry as well as the system.dat and user.dat files as outlined for your operating system in the Microsoft Knowledge Base.  Additional information about the registry is also contained in the Help topics in the Microsoft Registry Editor.

About the Author

Heather Volk

Sr. Technical Support Specialist, Building Solutions<br><br>Heather is responsible for responding to customer requests and helping them address technical challenges in a timely manner. She is an experienced Computer Aided Design Manager with a demonstrated history of working in the construction industry. She has strong arts and design professional skills in AutoCAD, plumbing, computer aided design (CAD), project estimation, and facility management, and a history of providing training and technical support.

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