Install Versus Deployment Folder Behavior Change

July 3, 2023 Ryan Wunderlich

Issue:
Starting with the introduction of the Custom Deployment / Custom Install options in your Autodesk Account there is a behavior change with specific user profile folders.  This is specific to the AutoCAD-based programs for product years 2022-Current.

This change now puts most of the folders under the Appdata\Roaming folder, instead of the Appdata\Local folder

Local user profile folders under Install Now or full Download (via AVA):
Folders in C:\Users\<username>\AppData\Local\Autodesk\AutoCAD 2024\R24.3\enu

Folders in C:\Users\<username>\AppData\Roaming\Autodesk\AutoCAD 2024\R24.3\enu

Local user profile folders under a Deployment or Custom Install (via online method):
Folders in C:\Users\<username>\AppData\Local\Autodesk\AutoCAD 2024\R24.3\enu

Folders in C:\Users\<username>\AppData\Roaming\Autodesk\AutoCAD 2024\R24.3\enu

Causes:
According to Autodesk, this is an as-designed behavior when using either a Custom install or deployment via your Autodesk account and should not affect custom deployments with included ARG files in the deployment.  Do be aware that if your base ARG file (profile) is from an Install Now or DLM download and you do not include it in the deployment, you will have to ensure that a few items are routed to the new folder paths.

The Template folder by default will be installed into LocalUserSupportFolder (AppData\Local) when using Install now or a full download install. But in Custom Install/Deployment workflows, Template folder will be redirected to [SupportContent]\Template.

The ones that are mainly affected are the following (Template and XREF Compare locations):
Install Now or DLM Paths for Template Settings:

Deployment or Custom Install paths for Template Settings:

It will also affect the location of the XREF Backup File Location:
Install Now or DLM install:

Deployment or Custom Install Location:

Note that the paths are not the same (and Options dialog will not tell you it’s an invalid location when applying and closing), and when you try to do a QNEW or New command, it will open the dialog box to either your My Documents folder or to C:\Program Files\Autodesk\AutoCAD 202x.

Solution:
There are two options to ensure this doesn’t occur:

  1. Add your ARG file to the deployment (per Autodesk)
    1. This doesn’t work for all products: https://resources.imaginit.com/support-blog/custom-arg-file-in-online-custom-deployment-not-working
    2. Doesn’t allow for on the fly changes – you have to rebuild the deployment with the new ARG
    3.  Not always ideal for your situation – we typically recommend this process:https://resources.imaginit.com/support-blog/best-practice-to-add-an-autocad-custom-profile-to-deployments
  2. Be aware that this will happen, if you manually load an ARG or manually set up an Icon with your profile and do not change the template locations from the defaults, that you will need to apply your ARG on a machine that used the deployment, change these paths to the new location (AppData\Roaming), and re-export the ARG file for use on other machines.  I would also double check any other paths in the Options => Files tab to ensure all locations referenced exist in the correct locations or (like the XREF Compare Path), you alter the locations to follow the custom deployment/install location.
     

About the Author

Ryan Wunderlich

Sr. Technical Support Specialist<br><br>An AutoCAD Certified Professional, Ryan is responsible for taking client cases and assisting with issues with the software - everything from regular glitches to software deployments and whatever else goes wrong. He's proficient in AutoCAD (including customization), VBA, LISP, and Civil 3D.

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