Revit Versions: Applied to all Revit versions.
Issue:
The Revit project file fails to load and gets stuck at the loading screen without providing any error or warning messages. The only way to close the program is by using the task manager and force closing the application. The loading bar stops moving and the model load gets stuck at a certain percentage.
Causes:
The main cause of this issue is due to a corrupted Autodesk Desktop Connector. The application encounters an error when attempting to bring linked files.
Solution:
To troubleshoot this issue, begin by closing the Autodesk Desktop Connector. If the Desktop Connector refuses to close and hangs, use the task manager to force close the application. Attempt to open the Revit project model with the Autodesk Desktop Connector turned off. If the file opens successfully, the Autodesk Desktop Connector requires reinstallation.
To perform a clean uninstall of Autodesk Desktop Connector, follow the instructions provided by Autodesk.
How to perform a clean uninstall of Autodesk Desktop Connector
If the Revit project file still fails to open after the Desktop Connector has been closed, the file may be corrupted. In this case, follow the instructions provided by Autodesk in the Help section on how to handle errors related to corrupt data in a file.
Help | Error: Data in File Is Corrupt | Autodesk
About the Author
Follow on Linkedin More Content by Gregory Lee