Autodesk Inventor File Check-in to Vault Fails Due to Save

March 25, 2022 Heath White

Issue:

Users experienced an issue where certain Inventor files do not appear to save even though the user repeatedly chooses to save the file. When attempting to check the file(s) into Vault, they are repeatedly presented with the following message:

 

 

Choosing “Yes” to save the file and move on to the Check In dialog does not result in the Check In dialog displaying. Also, the file status in the browser will still indicate that the file needs to be saved.

Causes:

The source of the problem was due to an iLogic Event Trigger, which was set to run after each file save. Because the rule modifies the file after each save, that causes the file to be recognized as “dirtied” and then prevents it from being checked into Vault.

Solution:

To resolve this issue, remove the Event Trigger that is causing the iLogic rule to run after the file is saved. The rule can still be run manually or using a different Event Trigger which does not dirty the file after a save.

 

See the following link for a short demonstration of the issue and its resolution.

 

About the Author

Heath White

Sr. Technical Support Specialist, Manufacturing

Follow on Linkedin More Content by Heath White
Previous Article
How to download the full updated version of the Autodesk Desktop App

How to download the full updated version of the Autodesk Desktop App when the Autodesk_Desktop_App_Bootstra...

Next Article
Autodesk Inventor - Unable to save changes to iParts
Autodesk Inventor - Unable to save changes to iParts

Solution to users suddenly being unable to save iParts in Autodesk Inventor.

×

Get Tips Delivered.

Subscribe to Email Updates.

First Name
Last Name
Country
Thank you!
Error - something went wrong!