Issue:
When installing or uninstalling the Autodesk On Demand Installer Service (AdODIS), during installation error troubleshooting, an error occurs referencing an AdODISInstaller.run.lock file.
Causes:
The file is locked. The lock will prevent any modification of the ODIS. This includes installing or uninstalling the AdODIS.
Solution:
The solution is to delete the lock file to allow the uninstall or reinstall of the AdODIS to complete.
- Open File Explorer and navigate to the path C:\ProgramData\Autodesk\ODIS.
- Delete the file lock file: AdODISInstaller.run.lock
- Continue with your uninstall or reinstall process. If you still need to uninstall the AdODIS, return to C:\Program Files\Autodesk\AdODIS\V1 to run the RemoveODIS.exe as administrator. If you need to reinstall the AdODIS, and you do not already have the AdODIS-installer.exe, then download the installer from the link below.
https://emsfs.autodesk.com/utility/odis/1/installer/latest/AdODIS-installer.exe
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