Issue:
Users are receiving a compatibility error when attempting to connect to the Vault Sever via a Vault Client. The error would look similar to what is shown in the following example:
Causes:
The issue as shown, is due to the client having been updated to a newer build (Service Pack) than the Vault Server build. Historically, you could often apply an update to the Vault Client without applying the same update to the server and, while doing so is strongly discouraged, it would not generate the error shown above.
With newer versions of Vault, this message pops up to help avoid compatibility issues between Vault Clients and the Vault Server by informing users of the discrepancy and preventing actions that could negatively impact your data.
To determine which Vault version the build numbers in the error correspond to, you can reference the following Autodesk KB article:
Solution:
There are two potential solutions to this issue and your Vault Administrator Team will need to decide which is appropriate for your organization. If you’re unsure which path to take don’t hesitate to reach out to the IMAGINiT Team for advice and/or assistance.
- The first option is to simply remove the offending Vault Client update from the user’s machine so that the Vault Client build number matches the Vault Server Build number. This is often the least disruptive to the overall Vault team. However, if all users have the update installed, it may be more prudent to update the Vault Server instead. In that event, option 2 may be the better choice for your organization.
- The second option is to update the Vault Server to the same build as the Vault Client(s) or a newer build if appropriate. Each release of Vault will have update instructions that should be followed for the best performance and user experience.
Note: As always, prior to performing any type of update/upgrade of the Vault Server, an ADMS Console backup should be performed and verified as part of your organization’s Disaster Recovery Plan.
The following links are for reference to assist you with whichever solution path you choose to pursue:
Vault 2022 Updates Install Information - https://knowledge.autodesk.com/support/vault-products/learn-explore/caas/CloudHelp/cloudhelp/2022/ENU/Vault-ReleaseNotes-CLC/files/updates/Vault-ReleaseNotes-CLC-updates-updates-install-information-html-html.html
Vault Updates from the AKN (choose your version) - https://knowledge.autodesk.com/support/vault-products/downloads?release=2022
If the solutions above do not resolve the issue you are experiencing, the following KB article contains advanced trouble shooting steps that should be performed by experienced Vault Administrators - https://knowledge.autodesk.com/support/vault-products/troubleshooting/caas/sfdcarticles/sfdcarticles/Error-is-not-compatible-with-the-following-applications-on-whilst-trying-to-connect-to-the-Vault-Server.html
Disaster Recovery Planning - https://knowledge.autodesk.com/support/vault-products/troubleshooting/caas/sfdcarticles/sfdcarticles/What-is-a-Vault-Disaster-Recovery-Plan.html
https://resources.imaginit.com/support-blog/vault-data-disaster-recovery
As always, if you need assistance with your Vault, please reach out to us here at IMAGINiT and we will be glad to provide you with assistance.
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