Vault backup task fails with Task Scheduler Error “A specified logon session does not exist”

March 19, 2024 Bob Felton

Issue:  

When using a Windows scheduled task for running the Vault Backup Utility that comes with the IMAGINiT Utilities for Vault Server, the task fails with a message:

"Unable to create Task...
System.Runtime.InteropServices.COMException:A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520)"

Causes:

There is a problem with permissions for the Windows UserID that specifies how the scheduled task should "Run As". For example:

Solution:

According to Microsoft's Tech Community article, the solution was first published in 2012. This error will only occur if the following Security Policy is enabled and you select the “Run whether user is logged on or not” Security option on the General tab, when creating a new task:

To correct this, run SECPOL.MSC

Then under Security Settings open  Local Policies > Security Options and select:

Network access: Do not allow storage of passwords and credentials for network authentication
 

Set this policy to Disabled.

According to the Microsoft Tech Community article:

"Task Scheduler uses Windows Credential Manager to store the credentials of the account that is specified to perform a task. If the Network access: Do not allow storage of passwords and credentials for network authentication policy is enabled and applied, Credential Manager cannot store the credentials locally, thus this error message appears."

About the Author

Bob Felton

Sr. Technical Support Specialist, Manufacturing<br><br>Bob Felton has been supporting Autodesk products for over 25 years including core AutoCAD, P&ID, Plant 3D, AutoCAD for Mac, AutoCAD Mechanical, and Vault. His background is in graphics with an Applied Sciences degree and ten years manufacturing experience drafting, as well as technical illustration, image editing, and even patent drafting.

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