Revit Version: Applied to all Revit versions.
Issue:
- Revit 3D orthographic view freezes and stop responding to any command but all other existing views are functioning normally.
- Newly created 3D orthographic view does not show any model elements and stop responding to any commands.
- Modifying existing 3D views may result in glitchy wireframe no matter which view style user is in.
Causes:
- The main cause for the issue is related to corrupted elements in the model
Solution:
Solution is rather simple, but it takes time to identify the corrupt elements. The easiest way to identify the corrupt element is to reach out to Autodesk technical support, but this will take some time to get the report back from them.
If customer needs urgent help, there are the couple options to identify the corrupt elements. Please follow below instructions to identify the corrupt elements in the project file.
- Make copy of the affected project file.
- Open duplicated project file and detach it from central.
- Save the file to local drive
- Save out the family by File > Save As > Library > Family
- Create temporary folder in your local hard drive where exported family will be saved. This folder will be deleted after identifying the corrupt family.
- If you see “Family Cannot be Saved” pop up, write down the name of the family on the note, and move to the next one. Note all the family that had a same pop-up.
- Close the copied the project file and open working project file.
- Delete all family that had a “Family Cannot be Saved” from the Project Browser since those families are corrupted ones.
- Sync to Central, and then close the project file
- Open the project file again, but this time make sure to check the Audit box before you open the file.
Follow instruction below if above steps did not find any corrupted family. If there isn’t corrupt family, the issue is within the system family such as floor, ceiling, roof, or annotation family.
To locate the corrupt system family, you will need to use the elimination process.
- Make copy of the affected project file.
- Open duplicated project file and detach it from central.
- Save the file to local drive
- Use visibility graphic to turn off all categories except for one.
- Delete entire visible elements in the working 3D view.
- Create new 3D view and check if the view function normally
- Check if affected 3D view is fixed. If not, select the next category, and repeat the process.
- If view is fixed after deleting the entire category, then, narrow the search by eliminating elements in the category until the corrupt element is found.
- Use IDs of selection to identify the corrupted element ID
- Open the original project file and select the object using , and enter the element id that you identified.
- Delete the affected element and sync the project file to central.
- Make sure to run audit after deleting the corrupted element from the file.
Following list of categories are common categories that may contains corrupt elements
- Walls
- Ceiling
- Roofs
- Floors
- Imported DWG
- Generic in-place family
- Topography
- Wall sweep
- Curtain wall mullion
If above steps did not locate the corrupted elements, reach out to Autodesk Support
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