Issue:
Sync jobs for BIM or Fusion cloud drives are failing to process on the Vault Job Processor. When you check the Job Processor, those Job Types are unavailable even though you have the Desktop Connector installed and running.
Causes:
This is typically due to the Job Processor starting before the Desktop Connector loads when the system starts up. This can often occur seemingly at random since the Sync Job Types will normally show as available and will process as long as the Desktop Connector started before the Job Processor.
However, the system hosting the Job Processor may restart for a variety of reasons, and if that happens, the Job Processor may start before the Desktop Connector, leaving the required jobs unavailable.
Solution:
To resolve this situation, you will need to delay the automatic start of the Job Processor so that it starts after the Desktop Connector to allow for Synchronization jobs to show up and be processed by the Job Processor.
The Job Processor itself does not have a built-in option for a delayed start, only the option to “Start on Windows Logon”. For the purpose of this solution, be sure that this option is NOT selected.
Since the Desktop Connector will start when the system starts up, you don’t have to make any changes to the Desktop Connector’s behavior. However, you will need to set a Windows Task to start the Job Processor. This will allow you to set a delay that will ensure the Job Processor starts after the Desktop Connector so the Synchronization Jobs will be available Job Types and can be processed.