Nastran 1603 Error on Installation – Possible Cause

October 10, 2022 Ryan Wunderlich

Issue:

You are attempting to Install Nastran and keep getting a 1603 Error during installation and cannot seem to get around it.

Causes:

This problem can be caused by a few things, but if other software (like Inventor), installed without any issues, we’ll need to dig deeper into the probable cause.  Nastran uses VB Scripts and utilizes the cscript.exe to run them, in many cases this is prevented and is causing the installation failure.

Solution:

What I discovered along the troubleshooting with Nastran specifically, is that the installer is launching a BAT file that is running CSRIPT command and that CSCRIPT is running VB scripts.  If your Environment is preventing the CSCRIPT from running, then the install will continue to fail.

1. First things first, we navigate to the ODIS folder after a failed installation (for 2022 and newer). If it is 2021 and older, skip to step 2.  These logs are located here:

%localappdata%\Autodesk\ODIS

Table

Description automatically generated

We open the Install.log file located there and search for NEWPFUI or NEPUF.bat

We should find a line similar to this:

[Install Manager: 305044, single] [InstallManager ERROR] [ InstallManager::HandleInstallFailure ]   Error Context: MSI (s) (08:DC) [11:14:27:571]: Product: Autodesk Inventor Nastran 2022 -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action Register_NEWPFUI, location: C:\Program Files\Autodesk\Inventor Nastran 2022\In-CAD\System\, command: C:\Program Files\Autodesk\Inventor Nastran 2022\In-CAD\System\NEPUF.bat

2. Now we want to validate and confirm CSCRIPT is present.

Click on the Windows Start Button and type in Advanced Settings and open the control panel item:

Graphical user interface, application

Description automatically generated 

Click on the Environment Variables button at the bottom:

Graphical user interface, text, application, email

Description automatically generated

In the System Variables portion, scroll down to Path and PATHEXT and confirm the presence of C:\Windows\System32 in the Path and that .VBS is listed in PATHEXT

Graphical user interface, text, application, email

Description automatically generated

If those are not present, you will need to edit each one and add them (or contact your IT support for assistance)

3. Now navigate to C:\Windows\System32 and confirm the presence of the cscript.exe

Graphical user interface, application

Description automatically generated

If all of that is there, now we need to confirm if there is a block or restriction on the cscript.exe, which prevents it from running.

4. Navigate to C:\Autodesk (or any other folder that is easy to get to).  Right mouse click anywhere not on a file or folder, then select New => Text Document

Graphical user interface, application

Description automatically generated

Name it test.txt
Graphical user interface, text, application

Description automatically generated

5. Now open the test.txt that was just created (using Notepad) and paste this single line of code into it:

Msgbox("Here")

Save and close the test.txt file

6. Now Rename the file to test.vbs (you may have to turn on file extensions to change the extension from txt to vbs)

Graphical user interface, text, application

Description automatically generated

7. Now click on the Windows Start button and type in CMD and open a command prompt

Graphical user interface

Description automatically generated

Once open navigate to C:\Autodesk (or where you created the test.vbs file).  Once in that folder type in

cscript test.vbs

and hit the Enter key and you should get this somewhere on your screen:

A screenshot of a computer

Description automatically generated with medium confidence

If you get this instead:

Text

Description automatically generated

That means you have a policy or restriction in place preventing the VBS script from running, and you will need to work with IT to have that block removed before you can successfully install Nastran.

 

About the Author

Ryan Wunderlich

Sr. Technical Support Specialist<br><br>An AutoCAD Certified Professional, Ryan is responsible for taking client cases and assisting with issues with the software - everything from regular glitches to software deployments and whatever else goes wrong. He's proficient in AutoCAD (including customization), VBA, LISP, and Civil 3D.

Follow on Linkedin More Content by Ryan Wunderlich
Previous Article
AutoCAD Aerial Maps Do Not Match Google Maps
AutoCAD Aerial Maps Do Not Match Google Maps

You have Geolocated your AutoCAD Drawing and the Aerial Map does not appear to be current, when checked aga...

Next Article
AutoCAD:  Heidi Module Load Error: “Error Loading Heidi Module – C:\Programs Files\Autodesk\AutoCAD 2022\DRV\\acaddm16.hdi”
AutoCAD: Heidi Module Load Error: “Error Loading Heidi Module – C:\Programs Files\Autodesk\AutoCAD 2022\DRV\\acaddm16.hdi”

This error indicates that either your Video Card and/or Video Card driver does not support DirectX 12. This...

Need tech support? Let us help!

Learn More