Issue:
Using Remote Desktop Connection(RDC) to connect to a remote machine give you LoadLibrary Error 126 (there can be other LoadLibrary Error codes for other AutoCAD vertical products, 126 is common for AutoCAD, 86 & 87 are common for Civil 3D, etc.)
Causes:
This is caused by the graphics engine on the local machine not being capable of handling the RDC connection to the machine with AutoCAD
Solution:
As we navigate new waters around here, I have run across this issue and want to inform you on the reason and provide a better answer than the Autodesk KB:https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/LoadLibrary-failed-with-error-126-when-starting-an-Autodesk-product.html
Here’s the actual issue, if a customer is trying to Remote Desktop Connection (RDC) from their home PC into their work PC, and an AutoCAD based product shows this, it may not be the ATI component. It’s how RDC works is it uses the host PC (user’s home PC) graphics engine to display what is on the remote PC. If they update the graphics drivers and still get that error, then they will need to investigate other options, since we cannot re-tune RDC or bypass it.
So, they will need to look at other screen sharing programs and cannot use RDC to accomplish their task. (like ConnectWise, LogMeIn Pro, Team Viewer, etc.) This generally only affects AutoCAD based programs.
You can investigate these options:
https://www.techradar.com/news/best-remote-desktop-software
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