Items Are Offscreen with Multiple Monitors of Different Resolutions

April 10, 2023 Ryan Wunderlich

Issue:
You have multiple monitors set up on your computer, and you have different resolutions between them and you do not have the screen scaling set the same for all monitors. When dragging a palette, dialog box or the like, it simply disappears from the screen entirely and you cannot locate or retrieve it. 

Causes:
You have multiple monitors set up on your computer, and you have different resolutions between them and you do not have the screen scaling set the same for all monitors.  For example:
 
Screen 1 is my primary screen, it’s UHD (3840 x 2160) resolution and is scaled at 200%
Screens 2 and 3 are additional monitors that only support HD (1920x1080), and are scaled at 100%

If I drag an item from screen 1 to 2 or 3, it can disappear entirely.


Solution:
This is caused by different screen scaling.  It’s also rooted in how the operating system handles that (when you drag to a lower screen scale, it will be extra large to a point, then reduce to normal:

The Chrome search bar is locally scaled at 100% on my HD monitor.
The Outlook message (purple) is still localized at 200% (it hasn’t readjusted to the 100%), when it does, this may change the position of the window I’m dragging, and that may cause you to lose the pointer on it and have it disappear.

The best way to fix that is to open the display settings (right mouse click anywhere on the desktop that is not an icon and select Display Settings):

In the Display settings wind that appears, click on each monitor listed in the screen above, scroll down to the Scale and Layout section, and set it to 100%, repeat with each monitor until all are at 100% (any UHD or higher screen may look microscopic – that is OK, we only need this as a temporary fix).

Once they are all at 100%, see if you can locate the missing dialog box, palette, etc., and relocate back onto the main screen, then make sure that it where it remains.  Save the workspace and close and reopen the program, make sure the location has remained, then put your scaling back to your preferred sizes.

About the Author

Ryan Wunderlich

Sr. Technical Support Specialist<br><br>An AutoCAD Certified Professional, Ryan is responsible for taking client cases and assisting with issues with the software - everything from regular glitches to software deployments and whatever else goes wrong. He's proficient in AutoCAD (including customization), VBA, LISP, and Civil 3D.

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