Troubleshooting Revit: Application Hangs or Spinning wheel

Issue:

  1. Revit (versions 2020/2021) hangs or the blue wheel spins when opening more than one project in same session.
  2. Revit (all version 2018-21) hangs or blue wheel spins when loading fabrication database or the Fabrication Addin (add-in) does not load.

Causes:

  1. Autodesk Revit Issues Addin for 2020 or 2021 is installed and the user is not using BIM360 products.
  2. Autodesk Revit Extension for Autodesk Fabrication is installed and user not using fabrication. This causes it to hang while it checks for it.

2a. If user is using the Revit extension for Fabrication and having issues with hanging, it is a known issue and Autodesk is working to resolve it.

Solution:

  1. Close Revit. Uninstall the Revit issues Addin from Control Panel

    Reopen Revit and test. Additional blog discussing this topic from Autodesk:

    Autodesk Article

  2. Close Revit. Uninstall the Revit Extension for Fabrication Addin from Control Panel:

Reopen Revit and test.

2a. The problem has been fixed in Revit 2022, see Autodesk article for more info:

Autodesk Article

About the Author

Heather Volk

Sr. Technical Support Specialist, Building Solutions<br><br>Heather is responsible for responding to customer requests and helping them address technical challenges in a timely manner. She is an experienced Computer Aided Design Manager with a demonstrated history of working in the construction industry. She has strong arts and design professional skills in AutoCAD, plumbing, computer aided design (CAD), project estimation, and facility management, and a history of providing training and technical support.

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