Vault Add-In won't load in Inventor-'System.IO.FileNotFoundException...'Autodesk.Inventor.Interop...'

Issue:

The Vault Add-In won't load in Inventor with an error similar to the following:

'System.IO.FileNotFoundException: Could not load file or assembly 'Autodesk.Inventor.Interop, Version=...'

Performing a repair on the 'Autodesk Inventor_version Add-In' in Control Panel doesn't get rid of the error.

Inventor-Interop-Add-In

Manually trying to load the Inventor Vault and Edm Add-ins keeps them unloaded.

Causes:

The error is caused by a missing folder and .dll file, see this Autodesk article:

"System.IO.FileNotFoundException: Could not load file of assembly 'Autodesk.Inventor.Interop, Version=##.#.#.#..." in Inventor when attempting to use or install the Vault Add-in

For example this based on the error above the following folder is missing:

Inventor-Interop-Add-In-NETfolder

Solution:

1.Uninstall and reinstall Vault Client to get the folder back.

2.Install the appropriate Vault Client updates based on the updates installed on Vault Server:

About the Author

Joanna Gryszka

Manufacturing Technical Support Specialist<br><br>Joanna has over eight years of experience working with Autodesk products. She started supporting core AutoCAD and network installations of all Autodesk products. She now has five years of experience with Inventor. <br> She graduated from Mechanical Engineering and has been providing solutions to clients and dedicating her knowledge to the Solution Center since then.

More Content by Joanna Gryszka
Previous Article
Identifying an Unknown Source Projection for Spatial Data in Map 3D or Civil 3D
Identifying an Unknown Source Projection for Spatial Data in Map 3D or Civil 3D

Have you ever tried to insert geolocated data or imagery into either AutoCAD Map 3D or Autodesk Civil 3D on...

Next Article
Does the AutoCAD for Mac 2019 include the specialized toolsets?
Does the AutoCAD for Mac 2019 include the specialized toolsets?

AutoCAD specialized toolsets only work on Windows and are not available for Mac users, unless they use a vi...